Fortran Coder

查看: 2325|回复: 6

[数学库] VS2013调用IMSL库函数错误

[复制链接]

10

帖子

5

主题

0

精华

入门

F 币
57 元
贡献
23 点
发表于 2022-10-15 17:45:36 | 显示全部楼层 |阅读模式
为什么我在VS2013下调用imsl库中的fftcf-int函数会报这个错误。但是我在VS2017状态下程序能正常运行。错误        1         error #7881: This module file was generated for a different platform or by an incompatible compiler or compiler release. It cannot be read.   [FFTCF_INT]
               

718

帖子

4

主题

0

精华

大师

农村外出务工人员

F 币
631 元
贡献
323 点

新人勋章爱心勋章水王勋章元老勋章热心勋章

发表于 2022-10-15 21:30:28 | 显示全部楼层
那就用VS2017呀。没什么理由坚持用旧版本。

822

帖子

2

主题

0

精华

大宗师

F 币
3875 元
贡献
2307 点
发表于 2022-10-16 09:37:48 | 显示全部楼层
imsl 、intel fortran两者的版本必须匹配。具体查相关版本imsl的release note就知道。

7

帖子

0

主题

0

精华

入门

F 币
53 元
贡献
20 点
发表于 2022-10-17 19:57:25 | 显示全部楼层
有可能是 32bit 和 64bit 没对上,检查以下你 imsl 的版本是不是 32 位的,是的话,程序构建也得 32 位。

10

帖子

5

主题

0

精华

入门

F 币
57 元
贡献
23 点
 楼主| 发表于 2022-10-18 10:07:14 | 显示全部楼层
楚香饭 发表于 2022-10-15 21:30
那就用VS2017呀。没什么理由坚持用旧版本。

好的谢谢老师

10

帖子

5

主题

0

精华

入门

F 币
57 元
贡献
23 点
 楼主| 发表于 2022-10-18 10:07:47 | 显示全部楼层
zoziha 发表于 2022-10-17 19:57
有可能是 32bit 和 64bit 没对上,检查以下你 imsl 的版本是不是 32 位的,是的话,程序构建也得 32 位。 ...

imsl是32位的,用的fnl600

10

帖子

5

主题

0

精华

入门

F 币
57 元
贡献
23 点
 楼主| 发表于 2023-4-27 10:54:53 | 显示全部楼层
zoziha 发表于 2022-10-17 19:57
有可能是 32bit 和 64bit 没对上,检查以下你 imsl 的版本是不是 32 位的,是的话,程序构建也得 32 位。 ...

是这个问题,已经解决了老师
您需要登录后才可以回帖 登录 | 极速注册

本版积分规则

捐赠本站|Archiver|关于我们 About Us|小黑屋|Fcode ( 京ICP备18005632-2号 )

GMT+8, 2024-7-22 07:32

Powered by Tencent X3.4

© 2013-2024 Tencent

快速回复 返回顶部 返回列表